408-754-4176 | info@reachtech.com

by Reach Technology
Support > Frequently Asked Questions > Troubleshooting: “Using Qt Quick 1 code model instead of Qt Quick 2” Error

Troubleshooting: “Using Qt Quick 1 code model instead of Qt Quick 2” Error

If when you switch to Design mode Qt-Design-Buttonyou get the, “Using Qt Quick 1 code model instead of Qt Quick 2 (M324) error,” you are probably using the wrong default kit. You should be using the “Qt 5.3.1 Desktop” kit. Follow these steps to update your kit:

  1. From the Qt Creator menu select Tools -> Options.
  2. Click the “Build and Run” option in the “Options” pane, on the left hand side.
  3. Under the “Kits” tab choose “Qt 5.3.1 Desktop” and click the “Make Default” button on the right hand side.
  4. Click the “Apply” button at the bottom right hand side.